18.04.2020

AntispamSniper для TheBat 3.3.4.4

[-] (pro) Устранена проблема с фильтрацией протокола SMTP когда SMTP порты (25, 465, 587) указаны в свойствах учетной записи в настройках плагина.

Как устранить проблему с сертификатами для gmail.com:

Недавно Google изменили SSL сертификаты для gmail.com. В результате более старые версии TheBat обрывают соединения с ошибкой типа "FETCH - Приветствие TLS не завершено. Недействительный сертификат сервера (Сертификат не может быть использован для этой цели)". Можно решить эту проблему с помощью настроек AntispamSniper.

Плагин поддерживает фильтрацию TLS соединений. Для этого он генерирует собственные сертификаты с исправленными проблемами, так что TheBat принимает их без ошибок. Чтобы включить эту функцию нужно сделать следующее:

- Установите корневой сертификат плагина как описано здесь.

- Включите все галки на вкладке настроек плагина "Учетные записи".

- Если фильтрация сообщений по заголовкам не требуется, выберите режим фильтрации "Фильтровать только на клиенте" на вкладке POP3 каждой учетной записи.

- Чтобы устранить проблему с SMTP соединениями, используемыми для исходящей почты, нужно добавить вручную новую учетную запись с любым именем сервера, и указать SMTP TLS порты на вкладках POP3 и IMAP. Например можно на вкладке POP3 указать порт 465, на вкладке IMAP порт 587.

Скачать (x32) Скачать (x64)*

*32-битные версии модулей расширения не работают в 64-битной версии The Bat! Если ваш модуль расширения перестал работать после установки 64-битной версии The Bat!, необходимо либо установить 64-битную версию модуля расширения, либо вернуться к использованию 32-битной версии The Bat!